Audio Reactivity and RealSense Integration


#41

One more thought: I noticed you are using USB 3.0 whereas we are using USB 3.2.
image

On one of the computers I do have USB 3.0 and I remember I had some problems with large bandwidth devices such as RealSenses and Kinects (although, as if on purpose, I can’t reproduce it on USB 3.0 today either).

Is there any chance you could try it out on a computer with a USB 3.2 port?

Lastly, I am going to send you testing a Lightact.exe file in a separate message. While I don’t expect this exe to fix your issues, it might give us some clues on what’s happening.

Thanks,
Mitja


#42

Hey Mitja,

Most confused now, as it works with the latest SDK 2.18.1; I did try the 2.17.1 and nada, still the same.

This is bizarre too:
image

You have 3.2 and I have 3.0, even though I have USB3.1, Type C ports. I states it’s VR Ready and that’s the one I’m using currently, mind you, I have tried the non VR Ready ports too.

Noticed too, that you have Driver Version: 10.0.17134.1, whereas I have 10.0.17763.1.

Please find attached a copy of my System Info, maybe this may shed some light on things:
ZEUS_12-02-2019_SystemInfo.txt (2.1 MB)

All the best.


#43

Well, that’s good. :slight_smile: These confusing sometimes-it-works-sometimes-it-doesn’t happened on our end with one of the older computers where the USB controller (I guess) is not the latest. On this computer I also have to wait a bit longer (5 seconds max though) for the RealSense list to refresh.

I hope you have plain sailing from now on, Dominic! :+1: Thanks for sticking with it!


#44

I think wee have our wires crossed, sorry. It works with the latest firmware and sdk for you, however, not for me, and neither does sdk 2.17.1.

I have a bang up to date PC, the System Info text file will state this.

I am currently in discussions with Intel re the D435i, however, no fix as of yet.

Really did think it would be as easy as running a setup.exe and within minutes the camera works with all associated apps; This is so not the case!

How come you have the USB3.2?


#45

Hey Dominic,

I posted the issues we are having on Github as well. At the moment, I’m at a bit of a loss at what else could we try except getting D435i.


#46

Really appreciated, thank you.
You and me both are at a loss then.

How come you have a USB3.2, please?
I just phoned MESH to discuss with their technical support, why I haven’t got 3.2 ports as this PC was supposed to be bang up to date. I ask if there was an interface card with USB3.2 and they stated one wasn’t available as yet.

Talk about frustrating, lol!


#47

Hey,

I honestly wouldn’t know about USB 3.2. It’s just what it says in the RealSense Viewer. Actually, the PCIe USB extension card says that they should be USB 3.0 :blush:


#48

All very confusing being as we have the same firmware/sdk and also >= USB3.0 ports.
I really don’t want to have to fork out another $190 for another camera that might give the same issues.

Thank you for your help =]


#49

Hey Mitja,

I’ve just ordered a USB 3.1 Type C lead to try that port as it states it’s high speed, hopefully come by Thursday.

Watch this space as they say =]


#50

Hey Dominic,

I hope this resolves your issues although somehow I doubt that USB connection is the cause. At the moment, my best candidate is incompatibility of D435i with the proposed API approach of getting the list of RealSense devices. It would help if we could get our hands on a D435i. If you feel like sending it over for us to test it feel free to do so.

I promise to send it back :slight_smile:


#51

Hey Mitja,

I hope so too but somehow doubt it. Apparently the type C connection is the smaller connection like the back of the camera. I have one port on the back of the PC so will give it a try anyway.
If this proves unsuccessful I will send the camera to you and if ok with you, the SR300 also, as Intel claim this should be ok to use; which it was in many of the your projects except for ‘TheDepthsOfYou’, which prompted me to update the camera to the D435, though I got the ‘i’ version, which defo doesn’t stand for ‘injection’, lol.

I really thought it would be plug, play and go, though days of misery has accompanied the installation.

What is your postal address, please?

So appreciate you’re ongoing help, thank you!!!


#52

Hey Dominic,

Please ship it to:

Mitja Prelovsek

Visible d.o.o.

Slomskova 23

SI-Ljubljana

Slovenia

Best regards,
Mitja


#53

Cool, thank you Mitja =]


#54

Hey Mitja,

My new camera has arrived and is installed.
Very pleased that I can run ‘TheDepthsOfYou’ project properly.

Thank you for all your help, I will post on the other two cameras for further investigation. Intel higher support never got back to me with the fix for the D435i, however, must admit Intel’s MartyG was a star; At least he responded continually.

Ok, if I may pick your brains again…
In relation to the ‘basicLightactIntegration’ and UE4, when I open up this map in UE4 and run the LA project, BasicLightactIntegration313, I find that:

the cube is rotating that is determined by LA, this is fine.
the texture set by LA is fine
the material set by LA is not showing on the middle display in UE4.

Please could you tell me why this should be?

Thank you.


#55

Hey Smudgy,

I’m really happy that it is working now.

I moved this question to a new topic.

Let’s chat over there.
Mitja


#56

Same same Mitja, it took ages and 3 cameras to get it right.

Will send on the others when I get round to it.

When I get paid this month, I will purchase the LA One license to get going properly with it.

Thank you for all your help, time and patience in this matter, really appreciated =].